Investigating an issue with Bulk device claiming in ThinkSmart Manager

Incident Report for ThinkSmart Manager Status

Investigating

We are currently investigating an issue where claiming devices in bulk using a csv file is not working in ThinkSmart Manager. All other device claiming methods are functional and working as expected. We will provide updates as progress is made on this investigation.
Posted Nov 24, 2025 - 20:20 UTC
This incident affects: ThinkSmart Manager Services.