Global AWS outage impacting device status in ThinkSmart Manager

Incident Report for ThinkSmart Manager Status

Resolved

The issues seen with invalid device status in ThinkSmart Manager is now resolved. We will continue to closely monitor.
Posted Oct 20, 2025 - 21:13 UTC

Investigating

Due to the global AWS outage status for devices in ThinkSmart Manager are showing as "Pending". We will continue to provide updates on this issue as progress is made on the investigation.
Posted Oct 20, 2025 - 13:01 UTC
This incident affected: ThinkSmart Manager Services.